Notifications
Mark all as read
Q&A

Welcome to Codidact Meta!

Codidact Meta is the meta-discussion site for the Codidact community network and the Codidact software. Whether you have bug reports or feature requests, support questions or rule discussions that touch the whole network – this is the site for you.

Can't edit a question just to add tags.

+1
−0

One can apparently not make an edit to a post just to change the tags. There is a message that nothing was changed because I didn't edit the post. Well, I didn't edit the body of the post, just the tags.

This makes it impossible to add/correct tags to otherwise perfectly fine questions, so I believe it should be regarded as a bug.


EDIT:

Specifically, I did this, and can reproduce it every time:

  • I wanted to edit this question on Software Development.

  • Add 4 tags, some are probably not yet created.

  • I type in these tags with space in between: C++ static thread_local dynamic-initialization static-storage-duration

    (static and thread_local are language keywords, dynamic initialization is a formal C++ term and static storage duration is a common formal term in C and C++ both.)

  • The site refuses the edit with the message "No changes were saved because you didn't edit the post."

Perhaps it is related to tag naming or by adding tags that don't exist?

Why does this post require moderator attention?
You might want to add some details to your flag.
Why should this post be closed?

5 comments

That's strange; I've definitely seen tag-only edits. Can you link to the post you tried to edit so we can figure out what might be special about that case? Monica Cellio‭ 14 days ago

@Monica Cellio‭ I updated the question with details of what I tried to do. Lundin‭ 13 days ago

@Moshi‭ Yes that's quite likely the same issue. Lundin‭ 13 days ago

0 answers

Sign up to answer this question »