Communities

Writing
Writing
Codidact Meta
Codidact Meta
The Great Outdoors
The Great Outdoors
Photography & Video
Photography & Video
Scientific Speculation
Scientific Speculation
Cooking
Cooking
Electrical Engineering
Electrical Engineering
Judaism
Judaism
Languages & Linguistics
Languages & Linguistics
Software Development
Software Development
Mathematics
Mathematics
Christianity
Christianity
Code Golf
Code Golf
Music
Music
Physics
Physics
Linux Systems
Linux Systems
Power Users
Power Users
Tabletop RPGs
Tabletop RPGs
tag:snake search within a tag
answers:0 unanswered questions
user:xxxx search by author id
score:0.5 posts with 0.5+ score
"snake oil" exact phrase
votes:4 posts with 4+ votes
created:<1w created < 1 week ago
post_type:xxxx type of post
Search help
Notifications
Mark all as read See all your notifications »
Q&A

Welcome to Codidact Meta!

Codidact Meta is the meta-discussion site for the Codidact community network and the Codidact software. Whether you have bug reports or feature requests, support questions or rule discussions that touch the whole network – this is the site for you.

Possible Markdown rendering issue

+7
−0

I identified a possible Markdown rendering error. In this post, I hyperlinked the last few words. This renders correctly in the preview but not in the actual post.

I’ve tested in a few browsers with same results.

For example, this is supposed to be a link.

Why does this post require moderator attention?
You might want to add some details to your flag.
Why should this post be closed?

1 comment thread

General comments (6 comments)

7 answers

You are accessing this answer with a direct link, so it's being shown above all other answers regardless of its score. You can return to the normal view.

+0
−0

Test cases (all look fine in the preview):

Link text edited to include period.

Link text contains no punctuation.

Other punctuation too?

What about comma, or exclamation point!

--

Copying text from the other answer to see if who posts it makes a difference (I sure hope not):

This post is a test to see if I can duplicate it.

Why does this post require moderator attention?
You might want to add some details to your flag.

0 comment threads

+6
−0

I seem to be able to consistently reproduce the issue. Steps taken:

  • Type (don’t copy a paste) a single sentence into an answer. End the sentence with punctuation (I’ve so far duplicated with a period and a question mark).

  • Select the last few words of the sentence including punctuation.

  • Click the link button in the editor.

  • Paste a link into the dialog.

  • Post the answer.

And just for good measure.

Why does this post require moderator attention?
You might want to add some details to your flag.

1 comment thread

General comments (2 comments)
+4
−0

I can confirm Laserkittens findings and reproduce the bug according to his instructions, however there is another detail that might perhaps explain Monicas failure to reproduce the bug.

During my tests, i noticed that the bug only manifests when i immediately click the Save/Post button after inserting the link via the Link button.

After inserting the link via the Link button, the text edit element loses the keyboard input focus. Just setting the input focus back to the text edit element (by clicking on it) before saving/posting was enough to prevent the bug from occuring.

The effect was also observable to me in the preview during editing. The link did not appear in the preview after adding it, but when clicking somewhere into the text edit element, the link appeared in the preview.

(I am using Firefox.)

Why does this post require moderator attention?
You might want to add some details to your flag.

1 comment thread

General comments (1 comment)
+0
−0

This post is a test to see if I can duplicate it.

Why does this post require moderator attention?
You might want to add some details to your flag.

1 comment thread

General comments (4 comments)
+0
−0

Can I do it again with a question mark?

Why does this post require moderator attention?
You might want to add some details to your flag.

1 comment thread

General comments (1 comment)
+0
−0

Test cases (all look fine in the preview):

Link text edited to include period.

Link text contains no punctuation.

Other punctuation too?

What about comma, or exclamation point!

--

Copying text from the other answer to see if who posts it makes a difference (I sure hope not):

This post is a test to see if I can duplicate it.

--

Another test: following the reproducer instructions in this answer.

--

Another test, as described in this answer.

Why does this post require moderator attention?
You might want to add some details to your flag.

1 comment thread

General comments (2 comments)
+0
−0

This post is a test to see if I can duplicate it

Why does this post require moderator attention?
You might want to add some details to your flag.

1 comment thread

General comments (3 comments)

Sign up to answer this question »