Communities

Writing
Writing
Codidact Meta
Codidact Meta
The Great Outdoors
The Great Outdoors
Photography & Video
Photography & Video
Scientific Speculation
Scientific Speculation
Cooking
Cooking
Electrical Engineering
Electrical Engineering
Judaism
Judaism
Languages & Linguistics
Languages & Linguistics
Software Development
Software Development
Mathematics
Mathematics
Christianity
Christianity
Code Golf
Code Golf
Music
Music
Physics
Physics

Dashboard
Notifications
Mark all as read
Q&A

Welcome to Codidact Meta!

Codidact Meta is the meta-discussion site for the Codidact community network and the Codidact software. Whether you have bug reports or feature requests, support questions or rule discussions that touch the whole network – this is the site for you.

Incorrect activity shown in question list

+2
−0

I've noticed this in several cases in the last day or so. The activity shown in the question list does not match the actual activity. Here is one example activity list entry:

Image

The actual question is at https://electrical.codidact.com/posts/279978. Inside that question it shows the question was written "16 hours ago", Andy's answer "43 minutes ago", and my answer "22 minutes ago". These values seem correct.

I tried doing a refresh (F5 in Edge) in the question list, but nothing changed.

I thought it might be some caching somewhere, so the question list data is a little old. That would be fine and understandable. However, note that it says "2 answers", but shows the activity of the first answer, not the latest. If it was just a 12 minute lag (again, no problem with that), then it still should have caught the second answer.

I just tried it again with a second browser tab, and still the same problem. It now says the most recent activity was Andy's answer "42 minutes ago" in the question list. In the question his answer is "about one hour ago" and mine "33 minutes ago".


I just noticed another case at https://scientific-speculation.codidact.com/posts/279974. The question list shows that last activity as being the question, although my answer obviously came later, and there were no edits to the question.

Why does this post require moderator attention?
You might want to add some details to your flag.
Why should this post be closed?

5 comments

I don't think this should be [status-completed]. Certainly the Scientific Speculation example is not fixed; the question still shows as "last activity 3 days ago by DonielF" in the questions list, but there is very clearly an answer that was "posted 2 days ago". Canina‭ 4 months ago

I found the unreported edit on Scientific Speculation. This seems to be the bug with suggested edits not being reported on the post. A different bug was marked as a dupe of this one; that other one was fixed but this wasn't. Monica Cellio‭ 4 months ago

This is completed as far as I can tell. Edits being applied updates last activity, and the bug of answers failing to has been fixed. ArtOfCode‭ 4 months ago

@ArtOfCode are you saying that it'll work right going forward, but the existing data errors will remain? If you check the links you'll see that those posts aren't being reported correctly; does that mean that edits that predate the fix will remain broken (but it won't happen again), or that there's still an issue? What behavior did you expect for this case? Thanks. Monica Cellio‭ 4 months ago

@MonicaCellio That'll be pre-existing errors. I'll try to run an update, but it may not catch every case. ArtOfCode‭ 4 months ago

0 answers

Sign up to answer this question »