Notifications
Sign Up Sign In
Q&A

"edit" link below non-Q&A post results in 404 Not Found

+4
−0

I tried to edit a recipe I'd posted, by using the "edit" link below the post text. That gave me a 404 Not Found error.

Looking at the URL, I noticed that it says /answers/.../edit, which is wrong because that's not an answer. (It's not a question, either.)

When I manually changed the URL to /articles/.../edit instead, editing worked fine and I was able to save my changes.

This is almost certainly related to URLs in RSS feeds wrongly assume that all top-level posts are questions (which has been fixed). Given that this is already two very similar bugs, I wouldn't be surprised if there are some other hardcoded assumptions elsewhere along the lines of "top-level posts are always questions, and anything that's not a question is an answer".

Why should this post be closed?

4 comments

That's weird; I edited a recipe last night. Investigating. Monica Cellio about 1 month ago

Ha! Here was me thinking I'd get away with this one because I had a fix about to go out... this should be fixed in the next... 5 minutes. ArtOfCode about 1 month ago

You can blame me for this bug. When I started working on suggested edits (which are now available BTW. Yay!), there were no articles yet. At that time, it made sense to say, that a post is either an question or an answer. When I added support for them, I wrongly kept some of these assumptions (as you guessed correctly). luap42 about 1 month ago

I'm probably one of the people who are least inclined to blame anyone specifically, @luap42 :-) I simply want the software that runs Codidact to be as good as it can be, and since I can't really contribute patches, I figure I can at least contribute clear bug reports so others can reproduce and ultimately fix the issues I encounter. cc @ArtOfCode aCVn about 1 month ago

0 answers

Sign up to answer this question »